Hardware and Software Requirements

To access and retain the information subject to this consent, you must have or have access to equipment that meets the hardware and software requirements:

  • Standard PC or Mac with at least a 1-GHz processor and 1 GB of RAM.
  • Available browser updates applied for improved security that provide anti-virus and spyware protection.
  • Microsoft Windows Vista Service Pack (SP) 2 and 3, Microsoft Windows 7/8/10, or Mac OS X.Cable, Digital Subscriber Line (DSL), or Integrated Services for Digital Network (ISDN) Internet connection. (Dial-up connections are not supported.)

For Windows users we suggest using the latest version of one of the following free web browsers:

  • Microsoft Internet Explorer 11.x
  • Microsoft Edge
  • Mozilla Firefox 33 and later
  • Google Chrome 37 and later
For Macintosh users we suggest using the latest version of one of the following web browsers:
  • Apple Safari 6 - 8
  • Apple Safari 9
  • Mozilla Firefox 33 and later
  • Google Chrome 37 and later

Certain older web browsers may not be supported by Gulf Coast Bank and Trust Company. If you're using an outdated version, you may need to update it in order to access your account(s) online. End users that try to log in without a compatible browser will be redirected to a website to download a new version of the browser.

Statements and certain Other Communications are available in PDF format only. You will need a program that accurately reads and displays PDF files (such as Adobe Reader). If you choose to use a third-party PDF vendor, Gulf Coast Bank and Trust cannot guarantee documents will appear as intended.

App requirements

This section describes the operating systems, connection types, and camera resolutions that are compatible with the Gulf Coast Bank and Trust Mobility Apps that end users can download from the Apple Store (for iOS devices) or Google Play (for Android devices).

Note the following details about Q2mobility Apps:

  • A valid email address and telephone number are required.
  • Digital Mobile Banking Apps function best when the GPS or native mapping app (also called Location Services) is enabled.
  • Android compatibility
    • Android 4.0.3 and later
  • Apple iOS compatibility
    • iOS 7.X
    • iOS 8.X
    • iOS 9.X
    • iOS 10.X

The following mobile operating systems are not compatible with Q2mobility Apps:

  • Windows
  • Blackberry
  • Kindle Fire

Mobile connectivity

  • 3 G
  • 4 G LTE
  • Wi-Fi